Installing Ubuntu on M2N68-AM Plus board

It’s been more than a decade since I started using Linux on the desktop. During that time I’ve installed and used various flavours (Red Hat, Suse, Yoper, Vector etc.) before finally settling on Ubuntu.

I’ve never attained Linux “god” status, though I’m usually able to find my way around things – keep that in mind while reading this guide 🙂

In the past decade, Linux as a desktop operating system, as well as its built in driver support has matured considerably. In fact, I can’t even recall the last time I had to resort to any sort of hack or work around for a successful install.

Today was a little different. This install took a little tweaking, so thought I’d post what worked for me, in case anyone else faces similar problems installing Ubuntu on this motherboard.

I’d picked up an old motherboard+CPU combo at work (ASUS motherboard M2N68-AM Plus with an AMD Athlon II X2 240), to set up a basic desktop for my Dad.

After I’d assembled the machine, I popped in the Ubuntu 14.04 LTS installation DVD and installed the OS without a hitch.

However, on booting up I faced the following problems:
1. First boot went fine right up till the log-in screen, I entered my password and everything froze and I had to do a hard reboot.
2. Second time I was not even able to even enter my password before the the cursor and the keyboard froze. Had to hard reboot again.
3. I played around a bit with the BIOS settings and this time I was able to log in and actually launch a few applications before everything froze again.

It was time to consult Google for information on what was going on.

After reading various forum threads, it seemed that the problem was most probably due to an errant Nvidia display driver. The ASUS M2N68-AM Plus motherboard ships with onboard Nvidia Geforce 7025/ Nforce 630a GPU and it seems Nvidia no longer supports or updates these (legacy product) drivers.

When I installed Ubuntu, I’d ‘checked’ the ‘install 3rd party drivers’ option, which meant that the (now unsupported) Nvidia drivers were installed – which were causing the problem.

Since I had no data on the system, I chose to do a fresh install. This time I opted to install only open source software.

Once the install was complete, I needed to install the (supported) Nvidia driver from Xorg. For this I followed the instructions at howopensource.com.

Step 1. Add the PPA repository (for Ubuntu 14.04 / 13.10 / 13.04 / 12.10) by typing the following command at the terminal

sudo apt-add-repository ppa:xorg-edgers/ppa

Step 2. Update system repository

sudo apt-get update

Step 3. Install the Xorg Nvidia driver

sudo apt-get install nvidia-current nvidia-settings

In stead of doing a reinstall, you can boot into a safe mode (press “esc” at boot time to view Ubuntu boot options) to remove the existing driver and replace it with the one from Xorg.

Ever since switching to the Xorg drivers, the system has been running like a charm.

HTH

  • John Buxton

    Abhijeet, for the technically illiterate ( and incompetent ) amongst us ( …… ie, ME ! ) could you provide a screenshot of your opening screen, indicate what browser you are using and explain just how easy it is to save downloads and photograph/music files etc ( AND access them afterwards. )
    I have no experience of Linux – Ubuntu or otherwise – and have no idea what is involved with using it.

    • John,

      I won’t be able to attach a screenshot in the comments here but will mail you a couple of screenshots later.

      I can assure you that switching to Ubuntu is actually simpler than switching from say Windoze XP to Windoze Vista/ 8!

      The standard browser installed is Firefox, though you can install and use Chromium (open source version of Google chrome) within a couple of steps.

      Standard office software installed is Libre Office, which can open and save M$-Office documents, sheets, etc. as well as directly save to PDF.

      Playing almost all video/ audio formats poses no special challenges and I have yet to resort to downloading any special codec to play a file (which was a common occurrence in XP).

      Downloads are automatically saved to the “downloads” folder.

      File operations are blazing fast: searching for files, copying, etc.

      Unless you use some specific proprietary software, which does not have a Linux version/ equivalent, migration to Ubuntu is quite painless.

      • John Buxton

        Still pretty scary for for a technoidiot like me !
        I – like a lot of other people – liked XP Pro. I acknowledge that it was pretty huge – and got a lot bigger over the years as more and more additions were made to it – and had shocking security aspects but it worked well and easily…… apart from Internet Explorer. Vista wasn`t as bad as people said …… it definitely wasn`t good however and was really a rapidly developed interim OS to address security problems. 7 ? Better than Vista ….. but not as good as XP Pro. 10 ? Yeah ……….. Having downloaded 10 a couple or three weeks ago I really wish I hadn`t bothered. It is, frankly, unfit for purpose and still needs a great deal of development. I really dislike the funky `apps` type treatment ….. most of which is advertising for MS products. It`s so bad that my wife – and Vikram – have both uninstalled and gone back to using 8.1. I would uninstall it and go back to using 7 but it`s `broken` …………. After a couple of days of use the browser ( Edge ) started to run very slowly …. and then pretty much not at all. I ran the latest version of C Cleaner ….. and it ceased cleaning after getting stuck on Edge after nearly 20 minutes cleaning. I started it again and it completed the clean in just over two hours. ( Normally a few seconds on Chrome ! ) I tried using edge again the next day with similar problems so decided to use Chrome instead …… but discovered that Edge runs in the background whether you want it to or not. Similar problems but Edge `broke` after cleaning and I can no longer access it …. although it still runs in the background and C Cleaner has to ask if it should turn Edge off ……. and a clean takes about 30 secs – 25 + of that on Chrome. I`m just venting my frustration really.

  • Hiren

    Thanks Abhijit, you had saved my life.

    for all those who are not able to go to terminal for the command Abhijit had in the post, try shortcut (ctrl+alt+T), when I was executing the last command I found couple of blinks at the end and the screen was not readable, I had hit hard restart button and things seems to be working fine.

  • Hiren,

    I’m glad you found the post useful and that’s a good tip – on the shortcut for launching a terminal window. 🙂

    Cheers!
    Abhijeet